Welcome to Black Liquid Software

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Sign in to follow this  
Followers 0
Ve5pa

Where can i get the patch??

Hi,

 

I see you awesome people at Black Liquid have come out with another Colonial Charter mod and I can't wait to play it! The only thing stopping me at the moment is the version of the game I have. I currently have a stand alone (non-steam) version of the game. The last time I updated it was for the 'Forge awakens' version of CC, so I think i'm on 1.0.4. I can't get the latest version and the mega mod to run ( I get a black screen when I try to enable the mod from the in game menu). I am pretty sure this is due to me being on a relatively old patch that doesn't support the latest version of CC. Does anyone know where I can download the patch 1.0.6 or later so as I can play the new version of CC?

 

I have looked on the official site where I got the game from (shiningrocksoftware) and they only have patches up to 1.0.4 and also I couldn't find anything here or on banishedinfo.com other searches on the internet tried to get me to download cracked version of 1.0.7 full game but I don't want to do this. 

 

tl:dr anyone got a mirror for 1.0.6 or 1.0.7 so I can update my game and get work on Journey xD

apologies if this is in the wrong section of the website. 

Edited by Ve5pa

Share this post


Link to post
Share on other sites

That's a very good question. I don't know if Luke ever released the patch that you need.

If you go to http://shiningrocksoftware.com/patch/ you can see the list of available patches.

But there's a step missing.  You can get from 1.0 to 1.0.5, but then there's no 1.0.5 to 1.0.6.  I don't know if the "1.0.6 to 1.0.7" patch will work with the 1.0.5 version of the game. (The only difference between 1.0.5 and 1.0.6 is very small, and they were released 16 days apart.)

Share this post


Link to post
Share on other sites

Hmm well i think i may be kinda stuck. I probably last updated when I got Forge awakens which will be a couple of days after SkyStorm did his previous youtube series. Now his channel has made me aware of the new patch and I would love to try it. What would be the best course of action do you think? Should i try to use a steam version? Is that better?

Share this post


Link to post
Share on other sites

Just a note that if you bought from ShiningRock then their latest updates are available via HumbleBundle - see http://www.shiningrocksoftware.com/contact-support/ for details. I can't check which version it is myself as I bought it from Gog, the latest there was 1.0.6 so its probably the same. 

Hope this helps :)

Share this post


Link to post
Share on other sites

Cheers, I might email them and state my initial order number etc and see what they can do for me. Thanks

 

edit. Okay I still have original email with the link to humble bundle website which will allow me to re download the game (updated version). Tomorrow I shall do a complete re-install and then I should be good to go. Thanks for your help folks xD

 

Edited by Ve5pa
1 person likes this

Share this post


Link to post
Share on other sites

le see if i can help with this. i have a 1.0 upgraded multiple times to a 1.05 build 160505 and CC journey works at that level. how many patch files do you have in your windata folder? i have 4 numbered 0-3 plus 2 datat files. you can get the 1.05 from shining rock. i actually have the 1.05 beta. the 1.06 was to fix a bug others were having. rename the 1.05 windata patch files to patch 2 and 3.,then copy the windata from the 1.04 to the new 1.05. make sure to link the banished app in the 1.05 to your desktop and u should be good to go for CC journey.

   when i did the upgrade to the 1.07 i did the same thing adding the 2 new files as patch 4 and 5.

Share this post


Link to post
Share on other sites
54 minutes ago, stiles said:

i have 4 numbered 0-3 plus 2 datat files

wait... in my [windata] are only four files:

data0.pkg + data1.pkg + patch0.pkg + patch1.pkg  (plus my mods *.pkm)

When you extract the BanishedPatch_1.0.6_To_1.0.7.170212.Beta into your Banished folder, data0.pkg and data1.pkg stay untouched, plus you get fresh patch0.pkg and patch1.pkg... why would you do all this copying and renaming as described above? Or end up with more files?

Just wondering  :)

 

@Kralyerg -

4 hours ago, Kralyerg said:

I don't know if the "1.0.6 to 1.0.7" patch will work with the 1.0.5 version of the game.

I'm pretty sure it does... coming from 1.0.4 like Ve5pa does, I'd probably run the "1.0.4 to 1.0.5" patch first (which had some major changes while 1.0.6 was just a hotfix) and then the "1.0.6 to 1.0.7" patch on top of that...

 

Share this post


Link to post
Share on other sites

PAENG, what version banished did you start with???  mine is a 1.0 duct taped and chicken wired together to work. lololol. if i replaced these files it won't work.don't pick on us poor folks that found a free game and spent too much time figuring out how we too could play with mods.lol my understanding of the 1.06 was it fixed 2 errors others were having. 1 was  something with orchards and the other was a error when they clicked on a townhall. so i skipped the 1.06.

Share this post


Link to post
Share on other sites

PAENG,i tried it your way, i took my extra patch files out. black screen. so i renamed the 2 files back to their original 0 and 1 #'s. goodie i now have music too. you fixed it.lol

 i put my files back and it says 1.07 beta build 170212 does that count?? i do wish you was right thou. it would be easier to explain it to someone else. that is why i asked how many files he had to start from the 1.04 since i thought he said he had startesd with the 1.0.  this trick or workaround could be used to bypass steam for other players also.

Share this post


Link to post
Share on other sites
15 hours ago, stiles said:

PAENG, what version banished did you start with???  mine is a 1.0 duct taped and chicken wired together to work. lololol. if i replaced these files it won't work.don't pick on us poor folks that found a free game and spent too much time figuring out how we too could play with mods.lol my understanding of the 1.06 was it fixed 2 errors others were having. 1 was  something with orchards and the other was a error when they clicked on a townhall. so i skipped the 1.06.

Since you are working with a copy that is an exception to the rules (sounds like a bootleg copy :(), please don't use the contortions you have to go through as an example of what people need to do.

2 people like this

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0