Welcome to Black Liquid Software

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Kralyerg

MegaMod 8 Beta 2 Discussion / Bug Reports

101 posts in this topic
38 minutes ago, estherhb said:

I tried it out and I believe it is working as designed. I built the "Forest Center", then laid down the special roads. It took a while for my Builders to complete all of the road squares and I had to really look to see which ones were totally finished. When I placed the districts/buildings (Herbalist, Gatherer, Hunter and Barn), all "thumped" but there was no visual confirmation that a building has been placed for construction.  It didn't take too long before Laborers brought over the materials required and Builders completed each district/building.  All I can guess is that you did not have enough workers and/or construction materials that were available (I had a lot of extra Laborers and Builders).

You're right, I just had to wait and the workers brought stuff to the construction site and the districts got built - thank you for the fast response and the work all of you put into this mod!

1 person likes this

Share this post


Link to post
Share on other sites
3 hours ago, Lola said:

I tried to place districts into RedKetchups Forest Center (after the 'special paths' have been built on the plots) and while the buildings turn green when I hover over the spaces and the 'thump' sound is played when I clicked there will be no blueprint put down for the workers to come and build the actual district. 

Edit: I have Banished updated to 1.0.7 and no other mods apart from the MM8 Beta 2

you wont see the blue print on the ground, but if you heard the "thump" sound, for sure it is there, don't put 5-6 of those. give the time to your citizens and builders to process it. i am not sure if you can "prioritize" those, i just hope you dont have tons of jobs waiting to be proceed before this blueprint.

Edited by Ketchup

Share this post


Link to post
Share on other sites
5 hours ago, Ketchup said:

thats because you use an old 1.0.5 custom material from an 1.0.5 old mod with the game upgraded to 1.0.6 +

what is your mod list Kmo ?

Hmmm ok, thanks for the quick reply! My mod list is attached, any tips on what could be causing it?

ModList.jpg

Share this post


Link to post
Share on other sites

Offhand I don't see anything obvious. However, you can get rid of Legalized Marijuana - it's included in MM8.  Rather than using X-treme Stockpiles (which is old - 1.0.4! - so it isn't necessarily compatible with Banished 1.0.7), I would use one of the Ridiculous Storage mods from Kralyerg's Kave which means smaller stockpiles can store a lot more stuff eliminating the need for huge stockpiles. I use Increased CC and it works great for me.  I don't know how compatible Tom Sawyer's Hunting mod is with MM8, especially since it was designed for 1.0.6, but to me it shouldn't affect crops..

I would try getting rid of Xtreme Stockpiles (and use one of the Ridiculous Storage mods instead) and Hunting (and Legalized MJ - just because you no longer need it) and starting a new game and see if you have the same problem.  

In the mean time, which crops are only shadows - who knows, maybe that's where the problem is.

Share this post


Link to post
Share on other sites

@Governor I tried disabling those mods one by one, and it was definitely the legalized marijuana mod that was causing the problem. I was able to disable it and reload my game and my plants are back. It was loads of different ones -- cotton, sunflowers, sugar beets, to name a few. Problem solved, cheers!

Share this post


Link to post
Share on other sites

Thanks for taking the time to fix the issue and letting us know what the problem was.  Kralyerg pointed out that you were using an old version of Medical Marijuana btw.

Share this post


Link to post
Share on other sites

Missing Carrots? Was regular carrots removed from MM8? I planted Horn Carrots but my inventory is missing an entry for either carrots or horn carrots. I cant make my beef stew and soup without carrots! :( I also just noticed the poor quality of the crops model -- horn carrots look like just specks of dust...even the blueberries (planted next to the peas) dont look like bushes and my farmers already started harvesting them. Already closed game so will try tomorrow to see if the issue persist.

I have MM8 beta 2, all the inedible mods, maritime mods (hopefully maritime will be added in MM8 soon) and the patch for the blast furnace.

2018-02-13_2047.png

Edited by Tamras
added installed mods

Share this post


Link to post
Share on other sites

@Tamras, it looks as though your Horn Carrots are only just starting to sprout/grow, they won't get to full size until the yield is 70%+

 

1 person likes this

Share this post


Link to post
Share on other sites
1 hour ago, Tamras said:

Missing Carrots? Was regular carrots removed from MM8? I planted Horn Carrots but my inventory is missing an entry for either carrots or horn carrots. I cant make my beef stew and soup without carrots! :( I also just noticed the poor quality of the crops model -- horn carrots look like just specks of dust...even the blueberries (planted next to the peas) dont look like bushes and my farmers already started harvesting them. Already closed game so will try tomorrow to see if the issue persist.

I have MM8 beta 2, all the inedible mods, maritime mods (hopefully maritime will be added in MM8 soon) and the patch for the blast furnace.

 

I tried this out to see if I could duplicate the problem. I asked the debug menu to give me all crop seeds and apparently there aren't any carrots but there are horn carrots.  I planted the horn carrots and blueberries.  At first, the crops looked just like the ones in your picture, but eventually the crops grew up and looked the way I expected.  The blueberries were harvested first (end of summer) while the horn carrots were harvested later.  The horn carrots were shown as carrots in both the barn and in the town hall inventory.  I'll check with Kralyerg, but I think the omission of "carrots" was deliberate because the mod that makes horn carrots replaces that.  

From the picture you submitted, I can't tell what time of year it is.  Please check to see if your crops eventually grow up and are harvested before year end.

blueberries and horn carrots.jpg

Share this post


Link to post
Share on other sites

Horn Carrots should not replace the other carrots.

Horn Carrots are made of the following files:

Seeds: NaturalResourceDSCarrotPlant.rsc

Horn Carrots: RawMaterialDSCarrots.rsc

 

CC carrots: RawMaterialCarrot.rsc

Share this post


Link to post
Share on other sites
On 2/13/2018 at 4:29 PM, Discrepancy said:

@Periandre, @WNovizar,

 

thank you for informing of the issue with the Blast Furnace.
It turns out this bug isn't isolated only to the mega-mod version.

I re-did the build points and made a patch mod:

DS Mods - Blast Furnace Patch

download available here from the Downloads section.

Installation: place the .pkm file in your Banished/WinData folder.
Enable in mod list and place above MegaMod and/or DS Blast Furnace & Industry Mining.
Exit completely out of game, then restart game to ensure smooth playing.
If adding to a save-game, demolish any Blast Furnace foundations in your town,
Enable the patch mod in the Pause mod menu, save and exit game, restart and load save-game.

Thank you for the patch, but unfortunately it still doesn't work, I am only using some Inedible mods and Megamod 8b2

Share this post


Link to post
Share on other sites
On 11/02/2018 at 5:20 PM, Vrayna said:

Are you using another mod, like maybe One Year is One Year?

No I'm currently only using megamod.

Tried various starting conditions not only the new ones and its still happening and these people are NOT mls away from their homes or anything like. There is always one house that becomes stuck with either no people or 1 person who keep disappearing and there is always 1 child left homeless no matter what I do. I demolish the house, reclaim it, it fills with a family, they then disappear and leave just 1 person in it...usually a child.

I've never had this problem until the new mod. I could send people miles away and never had this homeless situation occurring.

I've spent the day testing other starting conditions and done about 7 so far not just new ones but old CC ones and it is still happening, as is the problem below with logs & textiles

ON another note....logs and textiles are linked for some reason. If I set my textiles limit to 3000 it applies automatically to logs too

Share this post


Link to post
Share on other sites

dont you build too many house ? like a family go in. then you build another non-wanted house, then the familly is splitting, usually the husband, and then you build another non-wanted house, then the wife leave to take ownership of the new house, leaving the 1 year child inside ??

 

 

are you sure you really needed this/those houses ? what told you that you needed some ?

did you found a child in one of your houses that had a job assignment (laborer and ++) ? and found an opposite gender that is at least at school ?

 

or your town hall told you that the number of familly available is higher than the number of homes built ?

Edited by Ketchup

Share this post


Link to post
Share on other sites
1 hour ago, phyllidadavenport said:

No I'm currently only using megamod.

Tried various starting conditions not only the new ones and its still happening and these people are NOT mls away from their homes or anything like. There is always one house that becomes stuck with either no people or 1 person who keep disappearing and there is always 1 child left homeless no matter what I do. I demolish the house, reclaim it, it fills with a family, they then disappear and leave just 1 person in it...usually a child.

I've never had this problem until the new mod. I could send people miles away and never had this homeless situation occurring.

I've spent the day testing other starting conditions and done about 7 so far not just new ones but old CC ones and it is still happening, as is the problem below with logs & textiles

ON another note....logs and textiles are linked for some reason. If I set my textiles limit to 3000 it applies automatically to logs too

I tried to duplicate the problems you are having but cannot.  My forester definitely stops working when the Log limit of 200 is reached vs the Textile Limit which I set at 2,000.  Problems with limits are usually caused by incompatible mods. Could you please double check that you are using Banished 1.0.7? (The version is shown at the bottom of the 1st screen for Banished.)

The map type should not create a problem where people become homeless. I couldn't get anyone to become homeless even by sending them much farther to gather stone.  (The Pike's maps were created by Red Ketchup btw.) If RK's analysis - that you are building too many houses - isn't the issue, then again, I have to wonder if it could be that you aren't using the most recent version of Banished. 

If none of these are it, could you please provide a picture of your town where you have a house with no people and shows your population?

Share this post


Link to post
Share on other sites

and a picture of your first tab of your townhall would be great too :)

1 person likes this

Share this post


Link to post
Share on other sites
4 hours ago, phyllidadavenport said:

ON another note....logs and textiles are linked for some reason. If I set my textiles limit to 3000 it applies automatically to logs too

There is one possibility I can think of that could be causing this. A typo somewhere.  If a modder tries to set a limit that doesn't exist, it will default to logs.  So if a specific building is coded wrong, it could say the word Textiles but really be accidentally be affecting Logs.

Share this post


Link to post
Share on other sites
23 hours ago, estherhb said:

I tried this out to see if I could duplicate the problem. I asked the debug menu to give me all crop seeds and apparently there aren't any carrots but there are horn carrots.  I planted the horn carrots and blueberries.  At first, the crops looked just like the ones in your picture, but eventually the crops grew up and looked the way I expected.  The blueberries were harvested first (end of summer) while the horn carrots were harvested later.  The horn carrots were shown as carrots in both the barn and in the town hall inventory.  I'll check with Kralyerg, but I think the omission of "carrots" was deliberate because the mod that makes horn carrots replaces that.  

From the picture you submitted, I can't tell what time of year it is.  Please check to see if your crops eventually grow up and are harvested before year end.

 

I planted both horn carrots and blueberries in early Spring. Could the simulation speed affect it? I was on 10x speed and by early autumn, the crops have't fully grown yet but the farmers started harvesting them already. I planted new crops and removed all the workers to let the crop grow.

 

2018-02-14_2205.png

Edited by Tamras

Share this post


Link to post
Share on other sites

Fatal Crash - Library from RK

Each time I build a library from [RK]'s mod, I get the fatal crash message. I tried it 3x and it crashed 3x. 

 

W.png

Share this post


Link to post
Share on other sites
6 minutes ago, Tamras said:

I planted both horn carrots and blueberries in early Spring. Could the simulation speed affect it? I was on 10x speed and by early autumn, the crops have't fully grown yet but the farmers started harvesting them already. I planted new crops and removed all the workers to let the crop grow.

 

According to Discrepancy, the Horn Carrots don't look mature until yield reaches over 70%. So I could see that 10x goes so fast that there isn't time for the crops to look mature. I'm confused as to why you removed the workers - in my experience, if you remove farmers at any time (including when one dies and is replaced), you will harvest less.  

Share this post


Link to post
Share on other sites
6 minutes ago, Tamras said:

Fatal Crash - Library from RK

Each time I build a library from [RK]'s mod, I get the fatal crash message. I tried it 3x and it crashed 3x. 

 

Thanks for letting us know. Kralyerg says he has already fixed that bug for the next release. :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now