Welcome to Black Liquid Software

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Sign in to follow this  
Followers 0
Jewels8

Latest Megamod..running jerky and slow

If anyone can assist here would be immensely appreciated, I have the latest megamod running and even the one previous similar problem, doesn't matter which map size, be it a small or large map the game is running slow frame rate and very jerky. My laptop is not very old, a few years and have a reasonably good graphics NVidia card and my OS is Windows 10, I have played Banished since it came out and have had every single expansion that came out and have enjoyed my years playing, its all I mainly play besides a dabble here and there in other city building games, Not many other games hold my attention anything like Banished..I am not sure what is the problem..why the game is so jerky even on a new start with very little on the map, I remember playing maps with about 1000 population and wasn't too much of a problem, I would just run it at 2x or 5x but now even at 1x speed its just so slow and jerky! also while I am playing the windows its like it minimises or something like that and the screen goes to the page where you save your game..it is so weird and frustrating playing the game with these problems. I will never stop playing modded Banished, Vanilla I only played for a very short time, there really isn't much to it. To BlackLiquid and all the wonderful people that have made mods for this game and who might be reading this, Thank you ever so much! This game has been the only thing that has my undivided attention and is a total joy to play and saved me from the mundane an possible insanity of life's challenges.
So if anyone has any idea what could be the problem I would love to hear from you. Thanks so much for taking the time to read this rather long post. Cheers, Julie

 

Share this post


Link to post
Share on other sites

Do things are bad like that all the time, or when you have the inventory window from the Town hall or TradePost open? Closing them often helps once the number of inventory lines becomes important as your production gets more varied. There's nothing anyone can do about that sadly, except play without inventories open and only look at them when needed.

Another thing that can help is regular restarts of the game, as that clears out a bunch of stuff from memory.

One last thing you can try is take the tree harvesting tool and clear out a bunch of trees from your map. That apparently helps some people. Trees naturally re-seed new trees around themselves during their life and die. The way the growth is balanced, as time goes on you end up with more and more trees (except along rivers or on hills) which can put a strain on your machine. I tend to keep things under control by ordering small patches of clear-cut all around the map on a regular basis.

 

Edit: I just saw (I need coffee) the bit about things beind bad from the start. Try map settings that use different types of trees. Some new ones or maps with super high amount of trees (the ones that mix all kinds, unless you play Lite version) could be the issue.

Are you using DirectX 9 or 11, and have you checked that the game hasn't reverted to using the intel video chip instead of your Nvidia or Radeon card? Keep CTRL pressed when starting the game to check the video options there before anything starts for real.

1 person likes this

Share this post


Link to post
Share on other sites

It was happening regardless whether I had the inventory open or not, on a new map with hardly any inventory. I have also tried maps with less trees or atleast there seems to be less trees like the tropical and bamboo trees any it did improve slightly. 

I have tried both DirectX 9 and 11 the same happens with both, I have checked that it is using the dedicated graphics card and it is using the Nvidia, it can be frustrating when you seems to have exausted many possibilites and really takes away the enjoyment of the game! Anyway I believe that I had a virus which affected the pc because it crashed and it is at repair shop now where they are wiping it clean and I will have to reinstall the game from scratch, hopefully It makes the difference! Thanks for your tip, much appreciated!☺️

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0