Welcome to Black Liquid Software

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

  • 0
Sign in to follow this  
Followers 0
phyllidadavenport

Memory Issue

Just wondering if anyone else has been having memory issues namely, all memory being used?

This has only happened this last week or so after various Steam updates so I'm putting it down to that. I now can't play longer than 30mins or so before the game locks up. 

I have 8g memory (it was a measly 4g and the game with megamod was impossible so upgraded to 8g). When I upgraded a few weeks ago, the game was great...such an improvement...no more waiting 15mins for the game to load and no more freezing on 50people or more! Now I'm back to square one with the game using 98% of physical memory 7,809,079 and 25% of cpu (which I dont' think is bad) but the memory issue is ruining the game play now

Tried a system restore, scanned for malware & viruses tried various alleged fixes on other sites but now after the restore its taking 15-20mins to boot up and will only run for about half an hour

Can't think what else to do so would be grateful for any help

8g ram, Win7ultimate, 

Share this post


Link to post
Share on other sites

6 answers to this question

  • 0

just in case..... you have a 64bits win7 ? and not a 32bits ?

Share this post


Link to post
Share on other sites
  • 0

aye 64bit

Re-seated my ram, no change

Shut down as many processes as humanly possible and no change

The cpu is overheating within minutes of loading Banished to the point where its actually switching off my system.

Nothing has changed at my end, no new programs hardware software. All was fine until a couple of days ago logged into Steam starting loading Banished, switched to browser for a few minutes and noticed everything was insanely slow. Closed browser opened task manager and 98% of memory used

Share this post


Link to post
Share on other sites
  • 0

should bring it to store/repairs and explain everything you have on this. there is surely something that is leaking your memory.

Share this post


Link to post
Share on other sites
  • 0

hmm costs a small fortune unfortunately to get it repaired at a shop. Normally I'm fine fixing stuff myself but this is just very strange indeed. I can't see it being Steam personally, I doubt any update would have the effect of redistributing and allocating ram. Ugh I'll see how it goes for a few days after all the diagnostics I've run

Share this post


Link to post
Share on other sites
  • 0

did you said you formatted your c:\ and reinstalled your win7 64bits ?

Share this post


Link to post
Share on other sites
  • 0

no I was trying to avoid having to re-format hd

but

I have found the cause of the problem!!! It seems in a windows update they included nvidia Geforce Experience package....I didn't want it or need it so rolled back my machine to an earlier restore point however the nvidia crap was still there. It caused untold problems and has taken 2 days to remove all trace from my pc. Seems many many people have had problems with this hidden package after updating windows but due to the issues I'll probably need at least a new hard drive now

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0