Welcome to Black Liquid Software

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

  • 0
Sign in to follow this  
Followers 0
QuantumAlice

MM8 Won't load

I have Banished on steam, I'm not sure which version if anyone can tell me where to look then I can provide that. Anywho, I downloaded and installed the mods as the directions states, however when I exit to let it reload my screen goes black for a long time, then I hear a little "ding" noise and finally I get the following message. "A fatal access violation has occurred in VideoDX9 and the game cannot continue." I have no other mods, I changed it from Direct X 11 to Direct X 9c, I've put it in window mode, I've done everything I can think of to get this mod running and it simply will not reload.  I'm really sad and frustrated because I want to play this and I can't understand why it won't work.

Share this post


Link to post
Share on other sites

6 answers to this question

  • 0

The Banished version is at the very bottom of the opening menu of the game.  It should be Banished 1.0.7 build 170910.

There's no simple answer.  Just to make sure:

  • You downloaded MM8 from this forum?
  • Extracted the 3 .pkm files from the .rar file and put those in your Banished > WinData folder? 
  • The following 4 files are also in there: data0.pkg, data1.pkg, patch0.pkg and patch1.pkg?
  • Then you loaded Banished, chose Mods and clicked on the 3 MegaMod files (MM1 should be on top, followed by 2, then 3), then exited Banished completely before starting a new game? (Make sure you do this every time you add or delete mods.)
  • You have no other mods activated?
  • Were you previously using CC 1.75? If you subscribed to it from Steam, did you unsubscribe and delete the .pkm from your WinData folder? (It is included in MM8.)

When you start Banished after this it will take a long time to load, giving you a black screen to look at. I find that DX11 loads faster; but others, like Vrayna, finds more crashes and sticks with DX9.  It could take as long as 15 minutes (maybe more) because it's a huge mod.  

Share this post


Link to post
Share on other sites
  • 0

If it gave you an error message mentioning DX9 when you crashed, it's worth trying to go back to DX11. Press CTRL while starting Banished to bring up the options menu before the game itself and change it from there. It might help you get past that initial loading issue. I've had a few rare crashes mid-game with DX11, that's why I stick to the longer loading times of DX9 (as it loads slow but fine for me). Emphasis on rare. :)

Share this post


Link to post
Share on other sites
  • 0
On 5/23/2018 at 10:49 AM, estherhb said:

The Banished version is at the very bottom of the opening menu of the game.  It should be Banished 1.0.7 build 170910.

There's no simple answer.  Just to make sure:

  • You downloaded MM8 from this forum?
  • Extracted the 3 .pkm files from the .rar file and put those in your Banished > WinData folder? 
  • The following 4 files are also in there: data0.pkg, data1.pkg, patch0.pkg and patch1.pkg?
  • Then you loaded Banished, chose Mods and clicked on the 3 MegaMod files (MM1 should be on top, followed by 2, then 3), then exited Banished completely before starting a new game? (Make sure you do this every time you add or delete mods.)
  • You have no other mods activated?
  • Were you previously using CC 1.75? If you subscribed to it from Steam, did you unsubscribe and delete the .pkm from your WinData folder? (It is included in MM8.)

When you start Banished after this it will take a long time to load, giving you a black screen to look at. I find that DX11 loads faster; but others, like Vrayna, finds more crashes and sticks with DX9.  It could take as long as 15 minutes (maybe more) because it's a huge mod.  

 

Hi there,,

I've just downloaded MM8, extract all the files into WinData folder.

I've also checked that all pkm files you mentioned are all in place.

And.. I've done everything as mentioned.

 

The only thing is.. my Banished version is 1.0.4 - Build 141103

Is that a problem? I taught the compatible version is already included in MM8

 

So.. would you kindly help me on this. Thanks.

Share this post


Link to post
Share on other sites
  • 0

Banished 1.0.4 is very much outdated.

If you got your game from GoG (that's the version you get if you got banished from HumbleBundle or directly from the dev's website), get the patches from there.

The current MegaMod will not work with earlier versions of Banished, only with Banished 1.0.7. Previous MM should work with Banished 1.0.5 and 1.0.6. I don't think even the earliest version of MM worked with Banished 1.0.4. I think you'd have to dig into the CC Archives to find some of the very early Colonial Charter mods to play with that early Banished.

 

Things that can happen if you try the current MegaMod with Banished 1.0.4: Simply crashing on map creation, appearing to work but crashing the moment you produce any item that has a flag/category the game can't handle, and crashing the first time you get a trader that brings something with a wrong flag. Basically, it'll crash, crash or crash.

Share this post


Link to post
Share on other sites
  • 0

most of people get their retail version from steam and gog and they are up to date because it is easy. those who arent updated mostly come from torrents and cracked pirated version and there is no update....

those people just need to find the new version 1.0.7 v 170910 at same place they found the other old version... torrent and whatsoever.

but i strongly suggest to buy it, 1 it is a super cheap game, 2; it comes very often in 33% and 66% sale... 3: this game deserve it.

Share this post


Link to post
Share on other sites
  • 0

GoG might not update automatically, so if you haven't played in a while, it's super forget all about updates. Until you look up new mods :D

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0