Welcome to Black Liquid Software

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Sign in to follow this  
Followers 0
Lord Vetinari

Cannot run MegaMod at all

Hi everybody. I'm new to the forums, but I've been playing Banished and Colonial Charter for a while. After a somewhat long hiatus with Banished, I felt the itch to play it coming back, I discovered this MegaMod and wanted to try it.


I don't know if this is a bug (unlikely) or a trouble with my own situation, so I make a new topic rather than posting in the bug reports. I can't run the mod in any way. When I try to enable the three files, Banished (Steam version, btw, in case it's important) first hangs up on a black screen during the restart process, then crashes.

I tried to enable MM only, I even tried to remove the files of the toher mods altogether. Nothing helps. Any suggestion?

Edited by Lord Vetinari

Share this post


Link to post
Share on other sites

all 3 ? did you tried to load just the 1st one or the 2nd or the 3rd part ?

what is your computer ? video card, OS, RAM, directX ?

Share this post


Link to post
Share on other sites

Are you using the most recent version of Banished - v. 1.0.7? Make sure you are using the current version of MegaMod which is 8.01 - there are older versions on Steam that you need to avoid. If so, all of the mods you use must be compatible with that. It is safer to only use mods that have specifically been modified or made to work with that version.  When you make any changes to your in-game mod list, be sure to exit Banished completely before going in and starting a new game.  At first, I would definitely only try loading MegaMod and disable all of your other mods. Make sure the 3 files are in order (1,2,3).  Depending on your system, it could take 10 minutes or more for it to load because it is HUGE.  I find that switching to DX 11 makes it load faster. Others find DX 9 is better (11 causes crashes).  

If that just won't work, try loading something smaller but still big such as Colonial Charter 1.76 and see if your computer can run that. (You don't want to use it with MM because it is included.) 

Let us know if you're successful!

Share this post


Link to post
Share on other sites

I'm having the same issues. After not having played Banished for a long time, I played it today with all my old mods, including Megamod 0.06. It worked fine, until I decided I wanted my mods up to date. I was very excited to find out about this new Megamod, so I downloaded it when I found it. That's when my troubles began. The game simply wouldn't load. I tried re-installing the game, unsubscribing from all workshop items, verifying the integrity of local files, the whole shebang. Just now I got into the opening screen of the game with Megamod (no other mods installed or subscribed), and it allowed me to start a new map, but while loading that it crashed and I got the message that "A fatal access violation has occurred in d3d11.dll"

I have 1.0.7 (Steam version) running on a Windows 10 pc, i5 7400 (3 GHz), 8 GB RAM

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0