Welcome to Black Liquid Software

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

  • 0
Sign in to follow this  
Followers 0
Nesr5

Coffee not Consumed in Coffee House

A few game-time years ago I traded for a supply of coffee (not coffee beans, but the prepared beverage) from a merchant for my coffee house.  It was promptly moved to the coffee house, but none of it has been consumed.  More recently I traded for some pipe tobacco and it seems to have the same problem (though I haven't given it a few years' trial).  The mead that is stored in the same coffee house is regularly consumed, but the coffee and pipe tobacco just sit there.  Do I have to manufacture a luxury in my town for it to be consumable?  Is there some way to trigger consumption?

Share this post


Link to post
Share on other sites

4 answers to this question

  • 0

Well, something bizarre happened.  The coffee house works now, but I don't know why.

A few days ago I wiped out all my mods, installed their latest versions, got CC 1.76 and put it above everything else except the mountain-less mines, unlimited mines/quarries, and improved herbalist/woodcutter etc., then started a new game.  I had the same problem with my coffee house.  Then I looked at my mods list so I could write it down and report it here and noticed I had two incompatible mods (decorative plants everything seasonal except trees AND decorative plants everything seasonal) turned on, so I turned one off and re-loaded my game (NOTE: I don't think these two incompatible mods were the problem, because before wiping my mod list clean I had only one turned on and the coffee house still malfunctioned).

After re-loading the game the coffee house still appeared not to function right (alcohol being consumed, but not coffee or tobacco).  Finally I tried putting in a different tavern (small tavern) to see if any of the luxury consuming buildings worked.  The small tavern took alcohol and tobacco from the coffee house, and suddenly BOTH the small tavern and the coffee house are working (though the tavern steals all the coffee house's non-coffee inventory!).  All luxuries are now being consumed.  Weird.

1 person likes this

Share this post


Link to post
Share on other sites
  • 0

It should be consumed. What mods do you have? What order? What are the version numbers?

Share this post


Link to post
Share on other sites
  • 0

I hoped I'd never have to list these, because I use a lot of mods!  But here they are, in their current order:

 

Improved herbalist, v4 - Yandersen

Unlimited mines and quarries, v1 - Banished Info

Improved woodcutter, v1 - Yandersen

Improved hunting cabin, v2 - Yandersen

Improved farming, v1 - Yandersen

Improved gatherer's hut, v3 - Yandersen

Improved forester's lodge, v3 - Kid + Yandersen

Advanced blacksmith, v1 - Zen Industries

Mountain-less Mines 2, v2 - PSIcho Ninja

CC: 1.71 Journey, v171 - BlackLiquid Team

DS terrains and climates, v1 - Discrepancy

Medieval town version 2.04.1.0.6 - RedKetchup

Grass guardian, v1 - Wallets

Kid-The mission 1.5, v1 - Kid

RK goats as livestock, v1 - RedKetchup

Pick me up, v1 - Owlchemist

DS fences and decorations, v1 - Discrepancy

Decorative items pack, v1 - RedKetchup

Decorative plants everything seasonal, v1 - Voeille

Pick & hen tavern, v1 - Discrepancy

Apiary (re-balanced), v1 - Shining Rock Software, LLC, RedKetchup

Cheap tunnels, v2 - Xez

DS bridge crossing, v2 - Discrepancy

DS small village-homes, v1 - Discrepancy

Dairy milk and creamery, v2 - RedKetchup

Red cottage, v3 - Tom Sawyer

Small town home, v1 - Discrepancy

Specialized stockpiles, v2 - Delver

Colorful little houses for 1.0.7, v2 - RedKetchup

Fish farm, v0 - Dio Jodianto

One year is one year-alternative version, v1 - Voeille

DS roasted nuts, v1 - Discrepancy

Rocks respawn, v2 - Owlchemist

Steph's grain silos, v2 - RedKetchup

Busy labourers, v2 - Darkbibou

Little chapel v2.0 - RedKetchup

Tombstone removal, v1 - ShockPuppet

 

I put these into the order I thought best, but I wouldn't be surprised if I've got them wrong.  Sometimes I'll put the DS Terrains & Climates above CC if I want to use them, but with my current game I'm using CC terrains & climates.

Share this post


Link to post
Share on other sites
  • 0

The #1 issue here is that you are using an old version of Colonial Charter - one that was not updated for use with Banished 1.0.7 which added a number of new flags (think "categories").  The current version of CC is 1.76 (not 1.71).

The #2 (and #3, #4, etc.) issue is that you are using a lot of older mods. Anything that was made prior to 9/2017 when Banished 1.0.7 was released may no longer work IF they can't use the new flags.  For example, mods that just add homes are usually OK because the flags used by homes didn't change.  

If I'm not playing with MegaMod 8.01, I use CC 1.76 with about 40 other mods. I usually download those from here and from WorldofBanished.com - using the mods listed as mods specific to 1.0.7.  I have seldom found an actual conflict by doing this. (BTW I also use Discrepancy's Pick & Hen Tavern v 1.1 and haven't had an issue with it.)

Hope that helps.

1 person likes this

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0