Welcome to Black Liquid Software

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

bumble_bri95

Fatal Access Violation

Hi all,
I know that there are other threads for this particular problem so I apologize for any redundancy. But I could really use someone's help. I posted a discussion on the Steam page of Colonial Charter 1.76 but no one has seemed to reply or maybe they don't know what I am talking about. But, to start off, please know that I am not super advanced when it comes to tech speak, that was my main issue with some of the other threads on this topic, I just simply could not understand what some people were talking about. I would say I'm intermediate at best. I love Banished, it's an amazing game and I finally bought it a few months ago on Steam. I keep it up to date and do not have any issues with gameplay in Vanilla mode. But I wanted some variety and tried to install Colonial Charter 1.76 about a month ago. The startup was normal, no issues. But after I tried to enable the mod and the game tries to restart, I get a "Fatal Access Violation" message and my game crashes. I have tried to look up tutorials on installing mods, thinking I was just missing something, but all the ones I have found are the same or download the mods from the Black Liquid website, so they weren't helpful. I have no other mods installed or subscribed to on Steam. I am playing on a laptop and thought that might be the problem but others have told me it works fine on laptops so I just don't know what to do. Please, please help if you can. Again I am sorry about the redundant thread but I'm getting desperate here. My computer specs: Intel(R) Core(TM) i5, CPU @1.60 GHz 1.80 GHz, RAM 8 GB, 64-bit operating system, Windows 10. Please let me know if any of you have ideas on what I can do or if I should give up on trying mods. Thank you for your time.

Also, I did get it to load up one time but as soon as the game saved, it crashed again and I haven't been able to get it to work again since
 

Share this post


Link to post
Share on other sites

Subscribing to a mod from the Steam Workshop should be the easy way to load this mod, but if that didn't work for you, I think you should download it from here. Before you do that, make sure you have unsubscribed to CC 1.76 from the Workshop. Then go to your Banished > WinData file and make sure the only files are data0.pkg, data1.pkg, patch0.pkg and patch1.pkg; you don't want a copy of 1.76 to already be in the folder. 

When you download 1.76 from here, it is a compressed .rar file. You will need to extract the .pkm file from that using a program that does that and put it in your Banished > WinData file.  I think Windows 10 has a program that will extract the .pkm file, but if not, 7-Zip can be downloaded for free from the web.

Start Banished and select CC 1.76 from the list of mods. Then exit the game completely before starting a new game. This will help prevent crashes.

Please let me know if this works for you.

Share this post


Link to post
Share on other sites

yep that exit completely and restart the game is vital. next step would be to pull up the task manager and exit any program that you do not need. this should give power for the computer to run the game otherwise all those other programs are using ram. have you tried to run the game not full screen? did you disable the auto saves? after that you could try some graphic changes. ohh what DX did you run it under? 9.0 or 11? i would try both. i don't use steam for banished but you could also try disconnecting from the internet and force the steam to run in off line mode. this would stop all the online features of steam from running and save that power drain. good luck

1 person likes this

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now