Welcome to Black Liquid Software

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

  • 0

alright, so a couple of hours ago, i was playing Banished, everything was fine until i decided to stop playing the game. now i hop back on and it's telling me the video card i have isn't able to create a DirectX 9 AND DirectX 11. here's what the error message says when it pops up

 
 
 
Quote

A fatal error has occurred and the application cannot continue

VideoDX9: The application failed to create a DirectX9 Device

Video device: Failed to initialize a video interface. The renderer DLL isn't loaded or isn't supported on the OS

VideoDX11: Failed to create color buffer with format DXGI_FORMAT_B8G8R8A8_UNORM [120x0 2xAA]

VideoDevice: Failed to load or initialize a Video Interface

I don't understand what's going on, im no tech wizard, as a matter of fact, im quite Technologically impaired. I would like to understand how to fix this issue so i can resume "Chill village building while listening to village music, The simulator"

banished error DX9 and DX11.png

Share this post


Link to post
Share on other sites

8 answers to this question

  • 0

i asked because maybe there was a registry data corrupted and cause a problem between the real video port and another one that exist but not used.

when you tried to uninstall / reinstall the game, did you made sure your windows registry didnt kept anything from previous install ?

i know there is a value that exist about video adapter in the registry , this value should be "0" if no video chipset on the motherboard...


is it possible your antivirus lock banished out from making writings in documents folders.... is Banished .exes and its folder in its exclusion list ?

there is so much thing can going on. but clearly your error popups talks about failing to start your directX. Hope you find.

Share this post


Link to post
Share on other sites
  • 0

something didnt closed properly and cannot start another instance of your dx9/dx11 ddl ?

should reboot your computer.

Share this post


Link to post
Share on other sites
  • 0

i did this, it did not work, so how do i reset DX9 and DX11 so the game can work properly? I tried reinstalling the game, didnt work, i tried validating the game files, nada. I'm not sure what to do now.

Share this post


Link to post
Share on other sites
  • 0

is it a portable with an integrated video chipset + you added a better video card ?
 

Share this post


Link to post
Share on other sites
  • 0

no, I'm using an old CyberPowerPC with a GTX 950 TI. the graphics card was added 2 years into the lifespan of the PC. my motherboard is pretty old as well as the processor. let me give you the specs. I was playing the game just this week and now somehow it just doesn't want to function anymore, it's weird.

specs:

 

pc specs.png

Share this post


Link to post
Share on other sites
  • 0

Okay, so right now I uninstalled my graphics drivers as well as my DirectX stuff so now I'm reinstalling everything. Will give feedback on results soon 

Edit: after successfully reinstalling my graphics drivers, my PC continues to give me the error in the OP for Banished. I'm restoring my PC to a previous version of itself when I didn't have that problem or the game installed. Let's see what happens

Edited by Jeff Belinger

Share this post


Link to post
Share on other sites
  • 0

Okay, so I fixed my driver issues by going back to a previous Windows save, now when I try to start the game, there'a .dump file that was created on start-up. How do I read it? I don't know how to open these files. Opening them in note block makes the file go haywire

Edit: completely removed all the local files for Banihsed, fresh installed it and now its working fine with the mods.

 

guess i fixed my own problems even though i know nothing about these kinds of things. at least Ketchup put me on the right track for this. requesting to close this thread.

Edited by Jeff Belinger

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now