Welcome to Black Liquid Software

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

  • 0
Sign in to follow this  
Followers 0
Hedge

Builders Acting as Laborers

I've noticed in a new game using CC 1.62 that builders would not build when all ressources were available and stockpiled. They would spend most of their time acting as normal laborers, picking up ressources and shuttling them to a nearby stockpile.

I've focused on several builders during that process and it does say 'xxxx (name) builder is picking up ressources' and so on just as if they were a laborer.

 

Anything wrong here? or might I have missed another post that answered that issue?

Share this post


Link to post
Share on other sites

7 answers to this question

  • 0

I have had this happen when I assign laborers to clear some patch of land. They are the ones that deliver the resources to the building site not the builders, so if they have been assigned something else to do, you have to wait until they are done. Or you can increase the priority for your building and they will deliver resources, then your builders will build it. 

1 person likes this

Share this post


Link to post
Share on other sites
  • 1

There's nothing the modkit can do to change the behavior of the citizens. The AI for them is hidden from us. Only the core game itself can tell the citizens what to do and where to go.

Share this post


Link to post
Share on other sites
  • 0

double check the resources. are they delivered to the building location? you didn't confuse iron ore with iron by chance? is there access to the building site,other side of river with no bridge,etc?

when you click each builder and then click the "tools" icon in the top right where does that builder point to? oh and i doubt you did this but did you oause the building? i do pause if i need the builder elsewhere or am low on a certain material.

Share this post


Link to post
Share on other sites
  • 0

Try reducing the number of builders to zero and then a bit later bring it back up to however many you want.

Share this post


Link to post
Share on other sites
  • 0

It wasn't a ressource availability issue, iron wasn'T necessary for the building either.

@Raerae it seems you were right when I reproduced the issue.

Clearing land was a job done by the laborers (though this is after I reproduced the issue, i wil never know if that is actually what caused the issue that brought me here at first) and once the building i queued up was cleared, all the ressources were brought and it only took me to turn builders back on for it to get finished.

Share this post


Link to post
Share on other sites
  • 0

In an instance where this is happening, you can usually sort it out by highlighting the building site with the priority tool. Some folks have a habit of doing so a couple times in a row to emphasize to the AI, "Hey you fools, come do this thing now!" 

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, Azure Lyrrix said:

Some folks have a habit of doing so a couple times in a row to emphasize

a.k.a. spamming the priority tool... guilty as charged  xD

 

1 person likes this

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0